User Tools

Site Tools


library-requirements

System requirements for building the ROHC library from sources

This page is for people installing the ROHC library from sources and/or packagers that want information to create packages for their favorite distribution.

System requirements for building the ROHC library from release archives

The following tools are required to build the ROHC library from release archives found on the download page:

Debian

On Debian systems, type as root:

  # apt-get install build-essential

Ubuntu

On Ubuntu systems, type as normal user:

  $ sudo apt-get install build-essential

CentOS 5.x

On CentOS 5.x systems, type as root:

  # yum install gcc make

CentOS 6.x

On CentOS 6.x systems, type as root:

  # yum install gcc make

Gentoo

On Gentoo systems, all tools are already installed.

Add your system here

To be completed by anyone…

System requirements for building the ROHC library from source repositories

The following tools are required to build the ROHC library from Git source repositories:

Debian

On Debian systems, type as root:

  # apt-get install automake autoconf libtool build-essential git

Ubuntu

On Ubuntu systems, type as normal user:

  $ sudo apt-get install automake autoconf libtool build-essential git

CentOS 5.x

FIXME Not tested yet on CentOS 5.x systems.

CentOS 6.x

On CentOS 6.x systems, type as root:

  # yum install gcc make git automake autoconf libtool

Gentoo

On Gentoo systems, type as root:

# emerge dev-vcs/git

Add your system here

To be completed by anyone…

System requirements for building and running ROHC tests

The following tools are required if you specify the --enable-rohc-tests option to the configure script:

  • libpcap, a portable C/C++ library for network traffic capture
  • cmocka, a unit testing framework for C (for versions >= 1.7.0)
  • sed
  • gawk

The additional following tools are required if you specify the --enable-rohc-tests-valgrind option to the configure script:

Debian

On Debian systems, type as root:

  # apt-get install libpcap libpcap-dev sed gawk
  # apt-get install libcmocka-dev            # for versions >= 1.7.0
  # apt-get install valgrind xsltproc        # optional, required for running library tests within Valgrind

note: package libcmocka-dev is available since Debian 8 (codename Jessie).

Ubuntu

On Ubuntu systems, type as normal user:

  $ sudo apt-get install libpcap libpcap-dev sed gawk
  $ sudo apt-get install libcmocka-dev        # for versions >= 1.7.0 only
  $ sudo apt-get install valgrind xsltproc    # optional, required for running library tests within Valgrind

note: package libcmocka-dev is available in the universe repository since Ubuntu 14.04 LTS.

CentOS 5.x

On CentOS 5.x systems, type as root:

  # yum install libpcap-devel sed gawk
  # yum install valgrind libxslt        # optional, required for running library tests within Valgrind

Note: as of August 10th 2013, cmocka is not in CentOS 5.x archive yet, so you need to install it from sources (for versions >= 1.7.0).

CentOS 6.x

On CentOS 6.x systems, type as root:

  # yum install libpcap libpcap-devel
  # yum install valgrind libxslt        # optional, required for running library tests within Valgrind

Note: as of August 10th 2013, cmocka is not in CentOS 6.x archive yet, so you need to install it from sources (for versions >= 1.7.0).

Gentoo

On Gentoo systems, type as root:

  # emerge libpcap sed
  # emerge cmocka                       # for versions >= 1.7.0
  # emerge valgrind xsltproc            # optional, required for running library tests within Valgrind

Add your system here

To be completed by anyone…

System requirements for building and running ROHC statistics

The following tools are required if you specify the --enable-app-stats option to the configure script:

  • libpcap
  • sed
  • grep
  • gnuplot
  • awk or gawk

Debian

On Debian systems, type as root:

  # apt-get install libpcap libpcap-dev sed coreutils gnuplot
  # apt-get install gawk

Ubuntu

On Ubuntu systems, type as normal user:

  $ sudo apt-get install libpcap libpcap-dev sed coreutils gnuplot
  $ sudo apt-get install gawk

CentOS 5.x

On CentOS 5.x systems, it does not work (gnuplot 4.0 patchlevel 0 seems to be too old).

CentOS 6.x

FIXME Not tested yet on CentOS 6.x systems.

Gentoo

On Gentoo systems, type as root:

  # emerge libpcap sed gnuplot gawk

Add your system here

To be completed by anyone…

System requirements for building API documentation

The following tools are required if you specify the --enable-doc option to the configure script:

  • doxygen
  • latex (not required for versions >= 2.0.0)
  • dot

Debian

On Debian systems, type as root:

  # apt-get install doxygen dot
  # apt-get install latex        # for versions < 2.0.0

FIXME to be checked

Ubuntu

On Ubuntu systems, type as normal user:

  $ sudo apt-get install doxygen dot
  $ sudo apt-get install latex          # for versions < 2.0.0

FIXME to be checked

CentOS 5.x

FIXME Not tested yet on CentOS 5.x systems.

CentOS 6.x

FIXME Not tested yet on CentOS 6.x systems.

Gentoo

On Gentoo systems, type as root:

  # USE='latex dot' emerge doxygen

Add your system here

To be completed by anyone…

library-requirements.txt · Last modified: 2015/05/25 16:00 by didier