User Tools

Site Tools


library-requirements

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

library-requirements [2015/05/25 15:52]
didier [Debian] update cmocka availability
library-requirements [2015/05/25 16:00] (current)
didier update for doc
Line 153: Line 153:
 ===== System requirements for building and running ROHC statistics ===== ===== System requirements for building and running ROHC statistics =====
  
-The following tools are required if you specify the %%--enable-rohc-stats%% option to the configure script:+The following tools are required if you specify the %%--enable-app-stats%% option to the configure script:
   * libpcap   * libpcap
   * sed   * sed
-  * sort+  * grep
   * gnuplot   * gnuplot
-  * gawk (for library versions >= 1.4.0) +  * awk or gawk
-  * tr (for library versions >= 1.4.0)+
  
 ==== Debian ==== ==== Debian ====
Line 165: Line 164:
 <​code>​ <​code>​
   # apt-get install libpcap libpcap-dev sed coreutils gnuplot   # apt-get install libpcap libpcap-dev sed coreutils gnuplot
-  # apt-get install gawk (for library versions >= 1.4.0)+  # apt-get install gawk
 </​code>​ </​code>​
  
Line 172: Line 171:
 <​code>​ <​code>​
   $ sudo apt-get install libpcap libpcap-dev sed coreutils gnuplot   $ sudo apt-get install libpcap libpcap-dev sed coreutils gnuplot
-  $ sudo apt-get install gawk (for library versions >= 1.4.0)+  $ sudo apt-get install gawk
 </​code>​ </​code>​
  
Line 184: Line 183:
 On Gentoo systems, type as root: On Gentoo systems, type as root:
 <​code>​ <​code>​
-  # emerge libpcap sed gnuplot +  # emerge libpcap sed gnuplot gawk
-  # emerge ​gawk (for library versions >= 1.4.0)+
 </​code>​ </​code>​
 +
 +==== Add your system here ====
 +To be completed by anyone...
  
  
Line 193: Line 194:
 The following tools are required if you specify the %%--enable-doc%% option to the configure script: The following tools are required if you specify the %%--enable-doc%% option to the configure script:
   * doxygen   * doxygen
-  * latex+  * latex (not required for versions >= 2.0.0)
   * dot   * dot
  
 +==== Debian ====
 On Debian systems, type as root: On Debian systems, type as root:
 <​code>​ <​code>​
-  # apt-get install doxygen ​latex dot+  # apt-get install doxygen dot 
 +  # apt-get install latex        # for versions < 2.0.0
 </​code>​ </​code>​
 FIXME to be checked FIXME to be checked
  
 +==== Ubuntu ====
 On Ubuntu systems, type as normal user: On Ubuntu systems, type as normal user:
 <​code>​ <​code>​
-  $ sudo apt-get install doxygen ​latex dot+  $ sudo apt-get install doxygen dot 
 +  $ sudo apt-get install latex          # for versions < 2.0.0
 </​code>​ </​code>​
 FIXME to be checked FIXME to be checked
  
 +==== CentOS 5.x ====
 FIXME Not tested yet on CentOS 5.x systems. FIXME Not tested yet on CentOS 5.x systems.
  
 +==== CentOS 6.x ====
 FIXME Not tested yet on CentOS 6.x systems. FIXME Not tested yet on CentOS 6.x systems.
  
 +==== Gentoo ====
 On Gentoo systems, type as root: On Gentoo systems, type as root:
 <​code>​ <​code>​
   # USE='​latex dot' emerge doxygen   # USE='​latex dot' emerge doxygen
 </​code>​ </​code>​
 +
 +==== Add your system here ====
 +To be completed by anyone...
  
library-requirements.txt · Last modified: 2015/05/25 16:00 by didier